For the context, I'm using EDPnet as a service provider. It should not change the configuration much for other providers using Belgacom's VDSL2. Irrespective of your provider, you'll still be connected to Belgacom equipment (Alcatel DSLAM), and they use an Ikanos chipset.
First of all, make sure you have an appropriate version of Cisco IOS runnig.
- With the Cisco 887V, the only version of IOS that I have found to be running fine is Cisco IOS 15.0(1)M5. Later releases introduce a new chipset firmware and VDSL does not sync anymore. This model has been replaced by the new multimode Cisco 887VA.
- With the Cisco 887VA, it works well for me with Cisco IOS 15.2(1)T. Both models are using Broadcom chipset, but the 887VA is multimode ADSL, ADSL2, ADSL2+ and VDSL2.
Here's the interesting part of the configuration:
controller VDSL 0
modem co5
modem co5
interface Ethernet0
no ip address
interface Ethernet0.10
description pppoe bridging from controller vdsl 0 to dialer 1
encapsulation dot1Q 10
ip nat outside
ip virtual-reassembly in
pppoe enable
pppoe-client dial-pool-number 1
description pppoe bridging from controller vdsl 0 to dialer 1
encapsulation dot1Q 10
ip nat outside
ip virtual-reassembly in
pppoe enable
pppoe-client dial-pool-number 1
interface ATM0
no ip address
no atm ilmi-keepalive
no ip address
no atm ilmi-keepalive
interface Vlan1
bandwidth inherit
ip address 192.168.2.1 255.255.255.0
bandwidth inherit
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
ppp direction callout
ppp ipcp header-compression ack
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
ip tcp adjust-mss 1452
!
interface Dialer1
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
ppp direction callout
ppp ipcp header-compression ack
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
ip nat inside source list 23 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer1
access-list 23 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip permit
As you can see, this is working:
887V#show controllers VDSL 0
Controller VDSL 0 is UP
Daemon Status: Up
XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'IKNS'
Chip Vendor Specific: 0x0000 0x0000
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' ' '
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0x0000
Serial Number Near: FCZ1509C0P5 887VA-K9 15.2(1)
Serial Number Far: ^A
Modem Version Near: 15.2(1)
Modem Version Far: 0x0000
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 17a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
SRA: disabled disabled
SRA count: 0 0
Bit swap: enabled enabled
Bit swap count: 10 18
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 14.0 dB 15.6 dB
Attainable Rate: 62532 kbits/s 18144 kbits/s
Actual Power: 12.9 dBm -13.2 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 7.8 16.8 26.7 N/A 14.4 21.6 N/A
Signal Attenuation(dB): 7.8 16.8 26.7 N/A 14.1 21.2 N/A
Noise Margin(dB): 14.2 16.1 12.6 N/A 17.3 15.2 N/A
Total FECS: 564 24344763
Total ES: 0 165
Total SES: 0 21
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
Controller VDSL 0 is UP
Daemon Status: Up
XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'IKNS'
Chip Vendor Specific: 0x0000 0x0000
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' ' '
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0x0000
Serial Number Near: FCZ1509C0P5 887VA-K9 15.2(1)
Serial Number Far: ^A
Modem Version Near: 15.2(1)
Modem Version Far: 0x0000
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 17a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
SRA: disabled disabled
SRA count: 0 0
Bit swap: enabled enabled
Bit swap count: 10 18
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 14.0 dB 15.6 dB
Attainable Rate: 62532 kbits/s 18144 kbits/s
Actual Power: 12.9 dBm -13.2 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 7.8 16.8 26.7 N/A 14.4 21.6 N/A
Signal Attenuation(dB): 7.8 16.8 26.7 N/A 14.1 21.2 N/A
Noise Margin(dB): 14.2 16.1 12.6 N/A 17.3 15.2 N/A
Total FECS: 564 24344763
Total ES: 0 165
Total SES: 0 21
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
8 commentaires:
great scott, heb je toevallig ook een idee hoe de iptv binnen te krijgen? Zit ik nog op te zoeken :(
do you also have an idea on how to get iptv working?
Here you find a IPTV config for the 886va
https://www.administrator.de/wissen/cisco-880-890-router-konfiguration-adsl-vdsl-anschluss-inkl-vpn-ip-tv-179345.html
Works without any issues.
I have used your example. It seems to work fine, but the PPP session gets lost after about a week. The line stays in sync (according to EDPNet). The session does not get back until a reboot of the router
This happens on 4 different ADSL and VDSL lines.
Any clues?
Hi Joris -- This was working for me until last week with EDPnet until I had to move to another platform due to Proximus vectoring compliance enforcement. Back to your question if PPPoE does not re-establish anymore, what does the log says? (try on the console "debug pppoe errors", "debug pppoe events", "debug pppoe packets")?
Instead of a reboot, what if you clear the PPPoE session instead ("clear pppoe all")?
If clearing works, then maybe a software upgrade of your IOS release will help. If you, you can also use EEM to execute the clear command once the interface falls down.
Hello Emmanuel,
This is a great post, thx for sharing the info.
How does it work nowadays with the Proximus vectoring compliance you were refering to?
You still get your cisco's internal modem working or you need the bbox in front of it?
Because this router is not whitelisted to be used on Proximus network, your profile will be downgraded to the repair state if you're not using one of the approved modems. As far as I know only their own BBox and some Fritz! modems are approved.
I'm personally using Fritz. This is a far cry from Cisco, but the best one can get at this point.
Hope this helps,
Emmanuel
Note that in my case it does not even work at all (the VDSL session is not establishing).
I added some pastes down here; if you have any clue that would be really nice :)
- vdsl debug : https://pastebin.com/WxYrsQdK
- show controller vdsl 0 : https://pastebin.com/XLPbFdwD
- cisco config; relevant parts : https://pastebin.com/iH9kxr5A
Enregistrer un commentaire